WordPress 3.1.2手动升级包

www.ihacklog.com-WordPress3.1.1-upgrade-to-WordPress3.1.2.zip (68.0 KB)

根据官方的消息,此次更新主要:
修复了一个允许贡献者(Contributor-level)身份用户不当地发布日志的bug
修复了按日志数量排序的用户查询(query)bug
修复了多个标签查询bug
修复了使用快速编辑来编辑页面时“过转义”日志标题的bug

上传文件后访问下:
wp-admin/upgrade.php

以下引用自:http://codex.wordpress.org/Version_3.1.2

Summary

Fix a vulnerability that allowed Contributor-level users to improperly publish posts. (r17710)
Fix user queries ordered by post count. (#17123)
Fix multiple tag queries. (#17054)
Prevent over-escaping of post titles when using Quick Edit for pages. (#17218)

List of Files Revised

wp-includes/post-template.php
wp-includes/version.php
wp-includes/user.php
wp-includes/query.php
readme.html
wp-admin/includes/class-wp-posts-list-table.php
wp-admin/includes/update-core.php
wp-admin/press-this.php

更多
17 Responses Post a comment
  1. Demon

    嗯。晚上回家去折腾一下看看。

  2. Demon

    我用FTP上传,插件下载不行。我用FTP下载打开正常。
    下载是使用浏览器的下载工具。CHROME的。以前我刚用你这插件时是正常的...可以下载的。
    后来不知道怎么的没也动过什么就不行了...囧...

  3. 荒野无灯

    刚去你博客试了下,下载下来文件是错误的,你确定文件完整地传上去了?我这下十几M大小的文件都没问题的。

  4. Demon

    大湿...你个下载插件。支持3.11么?怎么现在我那上传的是文件是好的。一下载来就出错了。

  5. 荒野无灯

    呵呵,貌似现在养成放手动升级包的习惯了。。。 :grin:

  6. 荒野无灯

    这个不用管了,是WP自身的问题,在升级那里点击隐藏此更新,过几天就会自动消失的。更新那里会显示“您使用的 WordPress 是最新版本。

  7. 最百科

    覆盖之后再访问了一下upgrade,提示无需更新数据库。然后再进入后台发现提示升级的黄条条仍然没有消失。这是肿么回事?

  8. ISayMe

    额,我是说用您的这个手动升级文件

  9. Demon

    还没升级呢。怕插件不支持了。

  10. ISayMe

    请问我修改的那些文件会不会被覆盖呢? 我好像修改了 程序文件夹里面的几个东西.怕升级会被覆盖

Leave a Reply

Note: You may use basic HTML in your comments. Your email address will not be published.

Subscribe to this comment feed via RSS