need PK compat. v6.3 (can do v4.6)

今天解压一个zip文件时发现有两个文件无法解压出来:

1
2
3
4
5
6
7
unzip checklist-v0.51.zip -d checklist
Archive:  checklist-v0.51.zip
   skipping: plugin/checklist.vim    need PK compat. v6.3 (can do v4.6)
   skipping: readme.markdown         need PK compat. v6.3 (can do v4.6)
   skipping: syntax/chklst.vim       need PK compat. v6.3 (can do v4.6)
   creating: checklist/plugin/
   creating: checklist/syntax/

从这个帖子中找到了答案:
[SOLVED] Unzipping File: "compat. v4.5" error – Ubuntu Forums

1
2
3
4
5
6
[admin@HuangYe VIM]$ file checklist-v0.51.zip
checklist-v0.51.zip: Zip archive data
[admin@HuangYe VIM]$ dd if=checklist-v0.51.zip count=2 bs=1
PK2+0 records in
2+0 records out
2 bytes (2 B) copied, 2.2559e-05 s, 88.7 kB/s

最后,

1
7za x checklist-v0.51.zip -ochecklist

搞定。

更多
No Responses Post a comment

Leave a Reply

Note: You may use basic HTML in your comments. Your email address will not be published.

Subscribe to this comment feed via RSS